OpenSuse specific Install

get dependencies

For gtk development install packages:

 sudo zypper install gtk2-devel
 sudo zypper install gcc-c++
 sudo zypper install libjpeg8-devel
 sudo zypper install libtiff-devel
 sudo zypper install libSM-devel
 sudo zypper install libnotify-devel
 sudo zypper install readline-devel
 sudo zypper install ncurses-devel
 sudo zypper install gettext-tools
 sudo zypper install freetype-devel

For Opengl and glut you need the Mesa libraries:

sudo zypper install freeglut-devel

wxArt2D uses cmake for generating makefile, and svn is needed to get wxArt2D from the repository.

sudo zypper install cmake 
sudo zypper install cmake-gui 
sudo zypper install subversion 

wxGTK

First wxWidgets should be installed. Download the latest version of wxGTK. Read how to install, should come down to something like the next. Configure compile and install for debug version like this:

cd wxGTK 
cd .. 
mkdir buildwxdebug 
cd buildwxdebug  
../wxGTK/configure --with-gtk --enable-debug --enable-debug_gdb --disable-shared --with-opengl --enable-threads


Wait for this to work: ../wxGTK/configure --with-gtk --enable-debug --enable-debug_gdb --disable-shared --with-opengl --enable-threads --enable-graphics_ctx  


make
sudo make install  
cd contrib 
make
sudo make install  

Notice that this is an outside of tree build, so you can easily make a next compile as only release. And as super user the default install is to /usr/local.

wxStedit

Optional to have lua scripting on top of wxArt2D.

Very likely not needed this step, since now included in wxLua itself.

Better get it fresh from CVS repository. And rename/copy its setup0.h to setup.h.

svn co https://wxcode.svn.sourceforge.net/svnroot/wxcode wxcode    
Copy the setup0.h to setup.h in stedit/include/wx/stedit  
./configure  make   
sudo make install  
sudo cp /usr/local/include/wx/stedit/setup0.h /usr/local/include/wx/stedit/setup.h  

After install, there is no install of the setup.h but still of setup0.h. For wxLua make sure you have a setup.h available somehow in your include paths.

wxLua

Optional to have lua scripting on top of wxArt2D.

svn checkout svn://svn.code.sf.net/p/wxlua/svn/trunk/wxLua wxLua
cmake-gui .

In cmake-gui, choose source and binary to /ThePathTo/wxLua. Set BUILD_SHARED_LIBS to off. Good idea is to set BUILD_VERBOSELY to on. Set BUILD_INSTALL_PREFIX to /usr/local. Set wxWidgets_USE_DEBUG to on.

make   
sudo make install 

wxArt2D

In case you want it with wxLua and wxStedit (which are both optional ) you need to set this:

export WXLUA=/pathToWxLuaSourceDir/wxLua 
export WXSTEDIT=/pathToWxSteditSourceDir/wxstedit 

Those paths are used to get to certain scripts which are not installed. Now first get a fresh copy of wxArt2D, checkout into directory wxArt2D here

svn checkout svn://svn.code.sf.net/p/wxart2d/code/trunk/wxArt2D wxArt2D

For the rest follow WxArt2dInstallCmake the Unix way.

wxArt2D: OpenSuseInstall (last edited 2016-04-27 13:45:36 by ip5657d226)